Home forums Makulu Core Chat Second display won't switch on

This topic contains 9 replies, has 2 voices, and was last updated by  rindi 4 months, 1 week ago.

  • Author
    Posts
  • #6159

    makstream
    Member

    Hi guys,
    Actually discovering Makulu Core, which is nice and runs smoothly, I however encounter a problem with my second screen which does not “come up.”

    I have two Radeon R9 380. Both screens are plugged on each DVI port for each video card.
    That configuration works fine for other (older) Linux Distributions and for Windows 7.

    But, with Makulu Core 15, the latest Manjaro and even Ubuntu 18.04.1, it does not.
    If I use the integrated tool to change resolution and manage screens (enable/disable), the first screen is always OK and the second is always shown switched on with the right resolution. Changing anything for that screen through that interface gives no improvement.

    The problem does not seem to come from lighdtm (Ubuntu 18.04) or from sddm (Makulu) because it is the same problem for each of those distributions.

    xrandr command sends back the right configurations for the screens and using the set of three ‘xrandr’ commands to setup a mode then to apply it changes nothing. The screen does not switch on.

    I also tried to install proprietary drivers instead of open driver. No change.

    So, I thought about X11. But I have not got a clue it is X11.
    So, I need a bit of help.

    Would someone give me a hand?

    Many thanks 🙂

  • #6160

    rindi
    Moderator

    I’m not sure I can help here, as my GPU’s are all older, and I usually only use 1 GPU which has multiple outputs (for example one VGA, one DVI on the same card, or 2 DVI’s on the same card), and there multiple displays work fine.

    But maybe if you just attach the output of xrandr, that might give some insight?

     

  • #6161

    makstream
    Member

    Thanks for your answer 🙂

    In fact, I tried to use only one card for display for both screens. Main screen was on a adaptor Mini-DisplayPort to DVI and second screen was on plugged to DVI port. Same problem. Except in that case, first screen was OK on Mini-DP and second was not on DVI (not switched on). Both were however plugged on one and only video card.

    I did many tests attaching the outputs through xrandr. No way.
    xrandr looks OK. It shows the numerous screen resolutions regarding the graphical cards output. It shows the configuration used for the screen which is stopped. And adding a mode, linking it to an output, then enabling it gives nothing. It looks exactly as if everything was ok. But the screen does not come up.

    As it works on other Linux distros with mesa or proprietary driver, I did not make the tests which would have consisted in plugging both screen on the second video card nor the one consisting in taking a video card out from configuration.

  • #6162

    rindi
    Moderator

    Have you tried plugging in the 2nd Display after logging in? On Ubuntu where a new 5.something kernel had been installed via UKUU, I was only able to use the 2nd display after logging in and the attaching the display. With the original 4.15.46 kernel (not installed via UKUU) that was not a problem. On Debian I havent had that problem either, using the current 4.19.0-4 kernel. So it could be a kernel issue and how it was built.

     

  • #6163

    makstream
    Member

    Hi,

    Just tried it. The expected configuration interface comes up when I plug the screen. But whatever the configuration I choose in it (mirrored displays, extent to the rights…) the configuration is used but the screen does not switch on.

    The previous versions of Linux I use have kernels older than 4.19

    I am strictly unable to say if this could come from a kernel problem. But I would be surprised to be the first one using two screens and having such a problem.

    However, this problem happens for Manjaro, Ubuntu 18.04.1 and Makulu. Maybe also for other distros I did not try. But, correct me if I am wrong, for Makulu and Manjaro, kernel is 4.19.

    So your comment about the kernel looks interesting.

    I am going to have a look to my Debian 9.8 which works fine actually. And I will see if I can update the kernel by degrees and look for a display malfunctioning.

    I will keep you in the loop.
    Thanks

  • #6164

    makstream
    Member

    Hi Guys,

    I just led a test over Debian 9.8
    I actually run a “factory” kernel 4.9.0.8

    I used the backports repo to get kernel 4.19.0.0-bpo4 installed.
    I confirm the problem is the same as soon as i restart Debian with kernel 4.19.

    Strictly the same as I encountered it through the latest Manjaro and Ubuntu 18.04.
    => Everything looks as if the screen was “on”.
    It is possible to send the mouse and everything to that screen
    It is possible to try to configure it differently through common display interface or through xrandr.
    But the screen will “NEVER” come up.

    In an other way, the screen is virtually OK for the system. But as it does not switch on, it is useless for the user I am.

    Both screens are OK up to Grub menu. Then I select an O/S with kernel 4.19.
    The problem takes place in the very first seconds after Grub launches initramfs.
    The second screen stops and never comes back up after that when the O/S is launched.

    I don’t know if that bug is already on the way to be patched.
    I suppose so.

    Does anybody know?

  • #6165

    rindi
    Moderator

    I have no idea. It seems also to do with your particular GPU type, as with my older GPU’s it works (AMD, nVidia and Intel). Maybe you should also check with AMD support about this issue.

    Another thing you can try, there is a utility in our repo, the radeon-profiler. You can try installing and running it. Besides giving you details on your GPU’s, it also alows you to change certain settings.

  • #6166

    rindi
    Moderator

    I found something that could have to do with this.

    First copy the files from /lib/firmware/radeon/ over to /lib/firmware/amdgu/ (To begin with don’t overwrite any files in the destination). Then rename /lib/firmware/radeon/ to something like /lib/firmware/radeon.orig/, or just move the folder somewhere else completely. After that create a symlink named /lib/firmware/radeon/ pointing to /lib/firmware/amdgpu/.

    Now reboot and check if it works.

  • #6167

    makstream
    Member

    I am sorry.
    I forgot to talk about that because I am used to it.

    I downloaded and installed the latest firmwares for AMDGPU for all the distributions I talked about.
    A classic case is when you do sudo update-grub, or sometimes during general updates.
    If those firmwares are missing, there is a message saying “Possible missing firmware in /lib/firmware/amdgpu…”

    Mostly, this also allow to know what is the right path where to put the firmware files 😉

  • #6168

    rindi
    Moderator

    But the above might still help, as it may still be using the wrong firmware. If you remove the radeon folder and and create a symlink called radeon pointing to the amdgpu folder, that should make sure an amdgpu firmware actually gets used (the utility I mentioned earlier, radeon-profiler, should also tell you which firmware is in use).

    A further way to make sure the correct driver is used is to have something like an amd-gpu.conf file in /etc/X11/xorg.conf.d/ with contents something like this:

    Section “Device”

    Identifier “AMDGPU”

    Driver “amdgpu”

    EndSection

    There could also be some further Options you could define in that file which might help, but for those I wouldn’t know the details.

    Although the Wiki article handles another problem, it might give you a general idea:

    Display Acting funny, Tearing, Cursor erratic, etc

You must be logged in to reply to this topic.